Checkout broken?

Hi, I’ve been trying to buy a 112 meals order. I do everything right, but when I get to checkout, it gets stuck at ‘Processing’ when I click ‘Place my order’.
I’ve disabled every extension I have, and it did not solve it.
I’ve ordered a sample and 2 bags previously, and everything went fine.
Please fix it quickly, since I’m going to move alone soon, so I’ll be going full Huel for maybe around 8 months.

Sorry for the inconvenience. Have you used a different browser and device? And have you cleared your cache?

If anyone else has the same problem then please let us know!

Well, just tried it in incognito mode on Chrome, which is the one I was using, and it worked.
Didn’t even try on normal mode, but I doubt it was a cache problem, since I cleared it with Ctrl+F5.
Maybe my connection just didn’t want to cooperate yesterday :stuck_out_tongue_closed_eyes:
Thanks for the help, anyways.

1 Like

Great stuff, glad you got that one sorted. Sometimes the Internet just needs to go to its room to cool off.

1 Like