Cant update subscriptions with new UI?

#1

It looks like the subscription UI has changed since my last order (YAY - the old one was bad!). BUT the new one doesnt seem to work? I have 3 bags - coffee, vanilla and mint chocolate - was heading in to change it up and all I get is “Modify Huel Powder Mint-Chocolate”, then a list of numbers from 2 - 16.

Does this new UI work for anyone else? I have a scheduled delivery soon… :S

0 Likes

#2

Hopefully it’s just a temporary problem. I also tried to update my subscriptions but gave up in the end because I couldn’t get an intelligible overview. I’ve temporarily cancelled all my subscriptions (since I also had scheduled deliveries that I wanted to skip) until it seems to work better.

0 Likes

#3

The one where you just activated a subscription and then chose flavors as before was better please revert

0 Likes

#4

Can you give this another go? I believe it might have been sorted.

0 Likes

#5

Also if I navigate back to the old subscriptions bit, it now shows upcoming orders as canceled? Can I just reactivate them there or do I have to use the new system?

0 Likes

#6

This now works, but my order has been dispatched in the meantime :frowning:

Hey ho…

At least the new UI is much better than the old one :slight_smile:

0 Likes

#7

I had to do a hard refresh before the edit screen would appear properly, incognito should work too. However all update requests are failing as bad request, the error message being “Invalid flavours”. Tried cancelling to create a new order but that didn’t work either. Request doesn’t look overly incorrect, have the product IDs been changed perhaps?

0 Likes

#8

Is this working for anyone else?

Since the change I can no longer change my flavour mix - after clicking “update” the progress “circle” whirls a bit and then eventually returns me to the subscriptions page with nothing changed.

Even worse is attempting to “Enchance” my box and add a new product. With this, the progress “circle” just keeps spinning forever.

0 Likes

#9

Seems to be working ok for me now. I managed to order the new bars and alter flavours in one of my subscriptions without any problems.

0 Likes

#10

Okay, thanks, maybe just me then :frowning:

Will wait a couple more days to see if it sorts itself out, and then contact customer support.

0 Likes

#11

@Bee UK, right ?

@dharkhig Also UK or different region ?

0 Likes

#12

Yes, I’m in the UK

0 Likes

#13

Ah okay, thought maybe it’s a regional problem but guess that one’s off now.

0 Likes

#14

Yes, Chris, UK for me.

0 Likes

#15

Could be a browser issue I suppose, but I get the same behaviour on both Chrome and Safari.

0 Likes

#16

Still issues, as in doubling the amount that needs to be paid.

0 Likes

#17

Definitely, I’m trying to add the new bars to my existing sub and what’s at the top of the list?
This:

0 Likes

#18

Yes, that page seems to be full of multiple items of the same product, which presumably shouldn’t all be visible (particularly the ones marked “wholesale”).

0 Likes

#19

There seem to have been some changes. I can now edit the flavour mix okay.

However, although adding a new product worked it was added at the wrong price. Removing it removed the product but left the total unchanged, so I am now being charged extra for nothing… :frowning:

EDIT: Logging out and back in again fixed the total.

0 Likes

#20

Woah
What is that? I want to try it

1 Like