Huel Website Inconsistencies

That Yoda’s been at it again!

1 Like

I think they’ve done this on purpose in order to increase forum traffic and entertain @hunzas as we all know how much he loves a good thread about no scoops.

On a serious note, thanks for taking the time to list all those issues @LukeSkywalker
I’ve also had difficulties with the new website but have been too lazy to flag up all the problems.

3 Likes

I posted this in my thread but this button isn’t working and just unleashes a blank space on you:

Edit: I’m calling it a button but it’s really a link. It could do with being made into a button as it’s looks a bit naff just two hyperlinks next to each other.

2 Likes

I can’t believe they would go to so much trouble, but I do appreciate the effort.

2 Likes

Hey Luke, you’re on our old subscription system. Are you using a bookmark to go back to it? The screenshot you’ve shared I don’t believe is visible anywhere on the new account management system…

Please go to huel.com, and click My Account in the top right. Maybe clear browsing history/cookies/cache if that doesn’t work. Your account should look like this:

image

Once you’re on the new account this is simple:

  • My account
  • Subscriptions
  • Drop down -> Enhance your box (Add to Box button)
  • Scroll down and scoops are there :+1:

Let me know if that works.

Hi, I am using https://uk.huel.com/ and I can also see the the page you have sent in your screenshot, the issue I, and other people are having is, if you click on “Subscriptions” on that page you sent or “Manage”, then “View Delivery” and “Edit” it just shows a blank page.

My cache is cleared.

1

The screenshot I sent, shows on mobile or if you make the browser smaller when you’re on the main Huel page. Like this:

2

3

1 Like

Tim I am having the same trouble and I am logging in via the main site and I not using an old bookmark.

The only way to edit a subscription on desktop is to shrink the browser and use the menu which appears in the top left corner and then go in that way.

Thanks for the workaround! This is really stupid. We shouldn’t have to deal with this kind of nonsense, they should fix their damn website, this is embarrassing.

Thanks for the work around, was having issues with it the other day just showing the blank section. Thought it may have been a Chrome issue but had the same in Edge (although it let me edit one subscription but not the other). Shrinking the browser window works for me.

Seems only some people are having problems. It’s all working fine for me.

Bee have you tried a Windows desktop with a maximised web browser?

No I haven’t. Will try my desktop shortly :+1:

Using desktop, Windows 7 with Chrome browser. I always have browser maximised. Working fine.

Am I right, saying there is no way to check the fulfillment of a certain dispatch date in a sub?
For example, order history has a 25 Feb order and next dispatch is 25 March.
Is there a way to see if the 25 Feb order is fulfilled/shipped?
Once I get a mail from DPD or UPS, it’s usually too late to change to a pick up shop if needed.

Except you’re on Windows 7 :innocent:

My machines are dual booted with Win10 and Win7. I usued to like Win10 when it first came out but now I prefer using Win7 :grin:

I don’t use Windows now just my trusty Android phone, I never did like Windows 10 I much prefer Windows 7.

I keep forgetting to boot into Win10 and update. Really must one of these days. Will no doubt be out of action for hours :roll_eyes:

Tim I have recorded my computer and DM’d you a link to the video so you can see what at least some of us are experiencing.

1 Like

Thanks for all the information here. Having chatted with the head of engineering, we’re working on a solution. The problem is routed in too much traffic and the subscription system we use basically tripping over itself. There’s no theme to who gets the issues, but we’re already working on the solution, it seems from this thread that many are fine. I can elaborate if you’d like but that’s the top line summary.

If you need changes made then get in touch with us.

@LukeSkywalker my apologies for not understanding the point you were making and thanks for the screenshots. Access to the old subscription through the mobile menu was a n oversight and should have now been solved.

Any other issues beyond the ones raised here, please log them below.

2 Likes