Edit button isn't working on the subscription page


I believe the edit button isn’t working on the subscription page. If you click it the screen just goes white and displays nothing. I’ve tried Chrome and Firefox and cleared all cookies etc with CCleaner. My OS is Windows 7.

I also think the edit and skip should be made more distinguishable as originally I read it as one hyperlink as they are both blue and I thought “what does edit skip mean?”.

If somebody else could verify if the edit button is / is not working for them it would be good.


Just tried it on my Android phone and it works ok for me. Will try and remember to check it on my PC tomorrow.

Working fine here as well on MacOS with chrome.

This is what I get when clicking edit:


That’s Firefox completely standard. No ad blocker or popup blocker.

I also tried IE11 but the portal doesn’t work at all with IE11. This is what I see after logging in.


I can’t get it to work on mobile or laptop. Annoying because I now have to try and get hold of them on the phone.

Really strange. Must only be certain areas. It works fine for me on laptop (Win7/Chrome) and on Android phone as mentioned above. I live in Cheshire.

Yeah works for me Coup, any luck this morning? Sorry for the problems.

still isn’t working, gonna keep ringing to try get someone to sort for me

Same here, tried Firefox and Chrome to no avail, turned off all AdBlockers, VPN, cleared cache, enabled cookies.

Edit: I’ve now tried Edge and IE on Windows 10, and Firefox and Chrome on Android to no avail.

It’s really annoying as I was having a bit of a mare with the webiste this morning and need to change both the flavours subsrcribed to, and the dispatch date :frowning:

Any ideas @Tim_Huel, are your web devs on the case?

I can’t try again on the pooter until this evening now.

It’s back up on mobile and desktop now, for me, at least.

Edit still isn’t working for me at home with either Chrome or Firefox. I have tried disabling my AV but it didn’t make any difference.

I also tried at work which is Windows 7 + IE11 and the behaviour was the same as what I got at home with IE11.

I just tried my Android (version 8) phone using Chrome and that also didn’t work. Clicking edit just gives me a blank white page.

This makes me think the issue is with my account rather than a global problem.

Luke Skywalker is having issues too. May this farce be with you.

Hi, I just noticed the issue you were having and I believe its an issue with Huel Desktop version of the website, rather than with you. If you snap the Huel website the to left or right side of your monitor an option should appear like this at the top left on the main page:
If you click on Menu and scroll down to “Manage Subscription Delivery” then from there the edit button should work for you.


@LukeSkywalker You sir are correct!

With my browser maximised I was clicking on “subscriptions and orders” on the left menu then the black view delivery button then clicking edit which took me to a white screen.

If I shrink my browser down to half size that menu button appears in the top left corner. From there if I click manage subscription delivery I can then view all subscriptions, active and old and click edit on the active one and change everything. This side of the website seems to still look like the pre-revamp version.

I’m not sure how this bug prevents the edit button from working on the newer side of the site though?


This is some serious dedication to Huel-buying!
Any other website and we would all have given up and bought else where by now
It’s like a game of crystal maze trying to work out how to order now :rofl:


yes…it is addictive. Hence the medication…I mean dedication.