Can’t access My Account! Help!

Hello, has anyone got any ideas why I’m getting stuck on “fetching your payment methods” when logging into my account?
It accepts my user name and password and I get the same issue on iPhone and Windows PC. Help! image

Accessing my account works for me which is of no help to you though. It does seem that different people are experiencing different problems with the website. If you have already tried multiple platforms and browsers then you will have to wait for @TimOfficialHuel to pop by and investigate.

Hey Dean, I’ve forwarded this one to the engineering team. Sorry for the trouble.

@TimOfficialHuel Thanks for the responses. I’ll keep trying but still experiencing same issue.

Hey Dean, could you try this one again? You should be able to login in now :blush:

1 Like

Hi @TimOfficialHuel yes I can access my account now! Thanks.

1 Like

Help, I’m having the same problem today. Can log on to my account but get the following ‘buffer’ issue…

Same issue.

Do I have wait for @TimOfficialHuel to pop by and investigate or can someone else help?

Have you tried emailing team@huel.com?

1 Like

Not yet, but thank you for the email address - it’s been one of those days!

1 Like

Tim and the staff are probably in the Pub now so wouldn’t get an answer unit tomorrow but your probably best emailing and hope they answer tomorrow.

3 Likes

We’ve got your email, Matt! We’ll check it out for you :+1:

1 Like

I wasn’t, god I really wish I was. :beers:

4 Likes

All working this morning, thank you everyone :wink: :+1:

2 Likes